CVE-2017-0898: Kernel.sprintf에 버퍼 언더런 취약점 발생

Kernel 모듈의 sprintf 메소드에 버퍼 언더런 취약점이 있습니다. 이 취약점은 CVE 아이디 CVE-2017-0898로 할당하였습니다.

세부 내용

* 문자를 포함한 악의적인 포맷 문자열과 함께 매우 큰 음수를 넘길 경우, 버퍼 언더런이 발생할 수 있습니다. 그럴 때, 결과로 힙 메모리를 출력하거나, 루비 인터프리터가 뻗을 수 있습니다.

해당 버전을 사용하는 모든 사용자는 즉시 업그레이드하기 바랍니다.

해당 버전

  • 루비 2.2 버전대: 2.2.7 이하
  • 루비 2.3 버전대: 2.3.4 이하
  • 루비 2.4 버전대: 2.4.1 이하
  • 리비전 58453 이전의 트렁크

도움을 준 사람

이 사안을 보고한 에얄 이트킨(aerodudrizzt)에게 감사합니다.

수정 이력

  • 2017-09-14 21:00:00 (KST) 최초 공개