Мы приостанавливаем поддержку Ruby 1.8.7

Я бы хотел сказать что-то эпичное, значимое, но, к сожалению, мой английский очень ограничен. Так что я просто скажу то, что скажу: это конец, как планировалось.

Про Ruby 1.8.7

Сейчас большинство из вас использует Ruby 1.9.x или 2.0.0 (ЕСЛИ НЕТ – ПОЖАЛУЙСТА, ИСПОЛЬЗУЙТЕ). В прошлом были другие версии, типа 1.4.x, 1.6.x и 1.8.x. Они являлись линейными потомками оригинального Ruby 1.0, так называемой MRI. Когда Матц опубликовал 1.8.0, это был творческий релиз. 1.8.7 был последним отпрыском того клана.

Технически говоря, уже десять лет прошло с того времени, как была опубликована версия 1.8.0, и пять лет с тех пор как опубликовали 1.8.7. В те времена Ruby использовался для написания CGI скриптов. Потом ситуация драматически изменилась с приходом Rails. Очень много людей стало использовать Ruby. И внутренне, мы наконец вмержили новый движок, который написал ko1 (тогда он назывался YARV). Движок стал каноническим Ruby, который вы используете сегодня.

Итак, после 10 лет я очень рад сказать, что 1.8.7 становится наследием. Он творил историю. Он менял жизни буквально. И чтобы продолжать меняться, мы двигаемся вперед. Ruby 2.0.0 просто отличный, но чтобы сделать подступающий 2.1 еще более прекрасным, я должен объявить о закате 1.8.7 и сфокусироваться на кровоточащем острие текущей ветки Ruby.

Спасибо тебе, 1.8.7, это была прекрасная жизнь для программы.

Про ВАШ Ruby 1.8.7

В вашей системе до сих пор может находится исполняющий файл Ruby 1.8.7. В зависимости от того, как вы устанавливали его, ваш Ruby 1.8.7 может быть, а может и не быть, поддерживаем кем-либо еще, потому что существуют сторонние организации, которые занимаются поддержкой Ruby 1.8.7. Единственная вещь, которую я могу сказать, это Я не хочу поддержвить его больше. Так что, если вы используете то, что опубликовал я, смотрите внимательней и ищите решения, подходящие к вашей ситуации.