Расширенная поддержка безопасности для Ruby 1.8.7 и 1.9.2

С настоящего момента версии 1.8.7 и 1.9.2 будут поддерживаться патчами для безопасности до июня 2014 года.

  • Команда разработчиков: Terence Lee (@hone02) и Zachary Scott (@_zzak)
  • После окончания 6-месячного периода возможно привлечение других разработчиков для продления срока подержки еще на 6 месяцев.

Спасибо Heroku за поддержку. Подробности можно прочитать в их блоге A Patch in Time: Securing Ruby.

Сообщения об ошибках

Во время периода расширенной поддержки будут накладываться только патчи для безопасности на версии 1.8.7 и 1.9.2.

Мы высоко ценим безопасность, и если вы найдете “дыру”, немедленно сообщите о ней на адрес security@ruby-lang.org. Это приватная подписка, и сообщения в ней публикуются только после исправления уязвимости.

Дальнейшая информация есть на ruby-lang.org/ru/security.

Выпуски новых версий

Как уже было сказано, будут накладываться только патчи для безопасности, увеличивая номер патч-левела.

Патченные версии 1.8.7 и 1.9.2 не появятся на ruby-lang.org. Однако вы можете собрать бинарные пакеты самостоятельно из исходников.

Причиной этому может служить то, что мы не принимаем новые заявки, а официальный релиз будет означать, что ruby-core несет ответственность за них. Команда разработчиков и без этого небольшая, и ей хотелось бы двигаться вперед и обновляться, а не поддерживать старые версии.

Зачем “откапывать” 1.8.7?

Около 6 месяцев назал было объявлено о закате 1.8.7.

В то время как команда ruby-core не собирается более поддерживать 1.8.7 и 1.9.2, Terence и Zachary будут поддерживать безопасность этих версий в рамках корпоративного спонсорства.

Ранее мы положительно относились к решению компаний о поддержке старых версий. В 2009 году поддержкой Ruby 1.8.6 занялся Engine Yard и выпустил версию 1.8.6-p369.

Напутствие

Сейчас хочется еще раз посоветовать вам обновиться до поддерживаемой версии Ruby. Немалое количество разработчиков пожертвовали огромным количеством времени, чтобы улучшить производительность и добавить новые возможности в Ruby 2.0+, и вы можете это использовать по полной!

Спасибо за продление поддержки! Давайте вместе сделаем Ruby лучше!