Ruby 1.9.2 sürüm yayınlandı

Ruby 1.9.2 yayınlandı. 1.9 serisinin en son kararlı sürümü.

Ruby 1.9.2 Hakkında

Yeni 1.9.2 aşağıdaki durumlar haricinde 1.9.1 ile tam uyumlu:

  • Birçok yeni metod
  • Yeni socket API (gelişmiş IPv6 desteği)
  • Yeni encoding'ler
  • Birçok farklı rastgele sayı üreteclerini destekleyen yeni Random sınıfı
  • Time tekrar tanımlandı. 2038 yılı bug'ı temizlendi.
  • regex düzeltmeleri
  • $: bulunulan klasörü içermiyor.
  • dl is reimplemented on top of libffi.
  • libyaml'yi saran yeni psych kütüphanesi syck kütüphanesi yerine kullanılabilir.

Ayrıntılı bilgi için NEWS ve ChangeLog adreslerine bakınız.

Ruby 1.9.2 RubySpec un %99 unu geçmiştir.

Desteklenen Platformlar

Ruby 1.9 dört seviyede destek verir.

Desteklenen
Ruby 1.9.2 nin sağlıklı çalıştığı denenmiştir.
  • Debian GNU/Linux 5.0 на IA32.
Çalışma yapılmış
Ruby 1.9.2 nin birçoğunda sağlıklı çalıştığı denenmiştir.
  • mswin32, x64-mswin64, mingw32
  • MacOS X 10.5 (Intel) and 10.6
  • FreeBSD 6 and later (amd64, IA32)
  • Solaris 10
  • Symbian OS
Çalışma yapılmış
Ruby 1.9.2 nin birçoğunda birkaç modifikasyonla sağlıklı çalıştığı denenmiştir. Yama gerektirir.
  • Other Linux distributions
  • Other versions of MacOS X.
  • cygwin
  • AIX 5
  • Other POSIX-compatible systems
  • BeOS (Haiku)

FAQ

Standart kütüphane /usr/local/lib/ruby/1.9.1 klasöründedir.
Bu versiyon "librariry compatible version" dur. Ruby 1.9.2 kütüphaneleri de 1.9.1 klasörüne konmuştur.
Bir LoadError kaynağı
$: bulunulan klasörü içermez. Bazı scriptlerde değişiklik yapmk gerekebilir.

İndirin