Ruby 1.9.2 RC1 릴리즈

Ruby 1.9.2 RC1이 릴리즈되었습니다. 이번 릴리즈는 1.9.2의 첫번째 릴리즈 후보입니다.

Ruby 1.9.2는 아래의 몇가지 항목을 제외하고, 1.9.1과의 호환성을 유지하고 있습니다.

  • 다수의 추가 메소드
  • 새로운 socket API(IPv6 지원)
  • 새로운 인코딩
  • 난수 생성을 위한 Random 클래스
  • 새롭게 쓰여진 Time 클래스。2038년 문제가 해결됨.
  • 몇 가지 정규식 확장
  • $:는 현재 디렉토리를 포함하지 않도록 됨.
  • dl은 libffi 상에서 새롭게 쓰여짐.
  • libyaml의 wrapper인 psych 라이브러리. syck의 대용으로 사용가능.

자세한 사항은 NEWSChangeLog을 참조하여 주십시오.

Ruby 1.9.2 preview 3 이후 약 130건의 버그가 수정되었습니다. Ruby 1.9.2의 알려진 버그는 #3462를 제외하고 모두 수정되었습니다.

Ruby 1.9.2은 8월초 릴리즈될 예정입니다. 1.9.2 릴리즈 스케쥴은 RubySpec 호환성을 위해 취소된 적이 있으나, 현재는 RubySpec 99%의 호환성을 보장하고 있습니다.

사용중 문제가 발생하였을 때에는 Ruby Issue Tracking System을 통해 문제점을 알려주시기 바랍니다.

다운로드