Arsip Tahun 2014

Ruby 2.1.4 Rilis

Ruby 2.1.4 telah dirilis.

Baca Selengkapnya...

Ruby 2.0.0-p594 Dirilis

Kami dengan senang hati mengumumkan Ruby 2.0.0-p594 telah dirilis.

Baca Selengkapnya...

Ruby 1.9.3-p550 Dirilis

Kami dengan senang hati mengumumkan Ruby 1.9.3-p550 telah dirilis.

Baca Selengkapnya...

CVE-2014-8080: Denial of Service pada Ekspansi XML

Ekspansi entity yang tidak dilarang dapat menyebabkan celah DoS pada REXML. Celah tersebut telah ditetapkan dalam CVE identifier CVE-2014-8080. Kami sangat merekomendasikan untuk memperbarui versi Ruby.

Baca Selengkapnya...

Perubahan Pengaturan Default dari ext/openssl

Kami telah mengubah pengaturan default dari ext/openssl di Ruby 2.1.4, Ruby 2.0.0-p594, dan Ruby 1.9.3-p550. Dengan perubahan ini, opsi SSL/TLS yang tidak aman saat ini dinonaktifkan secara default. Namun, dengan adanya perubahan ini, terdapat sebuah kemungkinan adanya masalah dalam koneksi SSL.

Baca Selengkapnya...

Ruby 1.9.3-p547 Dirilis

Ruby 1.9.3-p547 telah dirilis.

Baca Selengkapnya...