2014 Archives

Ruby 2.2.0 est disponible

Nous avons le plaisir de vous annoncer la sortie de Ruby 2.2.0.

Lire la suite...

Ruby 2.2.0-rc1 est disponible

Nous avons le plaisir de vous annoncer la sortie de Ruby 2.2.0-rc1. Après cette version, tous les changements seront limités à des corrections de bugs. La version finale de Ruby 2.2.0 est planifié pour le 25 décembre 2014.

Lire la suite...

Ruby 2.2.0-preview2 est disponible

Nous avons le plaisir de vous annoncer la sortie de Ruby 2.2.0-preview2.

Lire la suite...

Ruby 2.1.5 est disponible

Ruby 2.1.5 est disponible.

Lire la suite...

Ruby 2.0.0-p598 est disponible

Nous sommes heureux de vous annoncer la sortie de Ruby 2.0.0-p598.

Lire la suite...

Ruby 1.9.3-p551 est disponible

Nous sommes heureux de vous annoncer la sortie de Ruby 1.9.3-p551.

Lire la suite...

CVE-2014-8090 : Un autre déni de service sur l'expansion XML

Une entité non restreinte peut mener à une vulnérabilité dans REXML, similaire aux failles “Vulnérabilité de type Déni de service par expansion des entités dans REXML (bombe XML, CVE-2013-1821)” et “CVE-2014-8080 : Déni de service sur l’expansion XML”. Cette vulnéranilité a reçu l’identifiant CVE CVE-2014-8090. Nous vous recommandons vivement de mettre à jour Ruby.

Lire la suite...

Appel à conférenciers pour le Tropical Ruby 2015

Tropical Ruby 2015, la conférence Ruby au bord de l’eau, se déroulera du 5 au 8 mars 2015 à Porto de Galinhas, une plage paradisiaque située sur la côte nord-est du Brésil.

Lire la suite...

Ruby 2.1.4 est disponible

Ruby 2.1.4 est disponible.

Lire la suite...

Ruby 2.0.0-p594 est disponible

Nous avons le plaisir de vous annoncer la sortie de Ruby 2.0.0-p594.

Lire la suite...

Ruby 1.9.3-p550 est disponible

Nous avons le plaisir de vous annoncer la sortie de Ruby 1.9.3-p550.

Lire la suite...

CVE-2014-8080 : Déni de service sur l'expansion XML

Une expansion d’entité sans restriction peut conduire à une vulnérabilité DoS dans REXML. Cette vulnérabilité a reçu un identifiant CVE-2014-8080. Nous recommandons grandement de mettre à jour Ruby.

Lire la suite...

Changement des options par défaut de ext/openssl

Nous avons changé les options par défaut de ext/openssl dans Ruby 2.1.4, Ruby 2.0.0-p594 et Ruby 1.9.3-p550. Avec ce changement, les options non-sécurisées de SSL/TLS sont désactivées par défaut. Cependant, avec ce changement, il se peut que certains problèmes apparaissent avec les connexions SSL.

Lire la suite...

Ruby 2.1.3 est disponible

Nous avons le plaisir d’annoncer la sortie de Ruby 2.1.3. Ceci est une version PATCH des versions stables 2.1.

Lire la suite...

Ruby 2.0.0-p576 est disponible

Nous avons le plaisir d’annoncer la sortie de Ruby 2.0.0-p576 pour célébrer la RubyKaigi2014 qui se déroule actuellement au Japon.

Lire la suite...

Sortie de Ruby 2.2.0-preview1

Nous avons le plaisir de vous annoncer la sortie de Ruby 2.2.0-preview1.

Lire la suite...

Appel à conférenciers pour ConFoo 2015

ConFoo est à la recherche de professionnels désireux de partager leur expertise lors de l’édition 2015, qui aura lieu du 18 au 20 février 2015. La date limite de dépôt des propositions est fixée au 22 septembre 2014.

Lire la suite...

Ouverture des inscriptions pour RubyKaigi 2014

Les inscriptions pour RubyKaigi 2014 sont à présent ouvertes.

Lire la suite...

Appel à candidature pour la conférence RubyWorld 2014

La conférence RubyWorld se tiendra à Matsue au Japon du 13 au 14 novembre 2014.

Lire la suite...

Arrêt temporaire des listes de diffusion

En raison d’un trop grand nombre de spam, les listes de diffusion (mailing lists) de Ruby ont été suspendues de façon temporaire.

Lire la suite...

Sortie de Ruby 1.9.3-p547

La version 1.9.3-p547 de Ruby vient de sortir !

Lire la suite...

Sortie de Ruby 2.1.2

La version 2.1.2 de Ruby vient de sortir !

Lire la suite...

Objections sur la vulnérabilité CVE-2014-2734

Il a récemment été mis en lumière une vulnérabilité qui pourrait affecter Ruby, en l’occurrence CVE-2014-2734. Toutefois, sur la base d’une analyse détaillée retranscrite ci-dessous, nous considérons que Ruby n’est pas concerné par cette faille de sécurité.

Lire la suite...

Sortie de Ruby 2.0.0-p481

La version 2.0.0-p481 de Ruby vient de sortir !

Lire la suite...

Faille OpenSSL critique dans l'extension TLS Heartbeat (CVE-2014-0160)

Une faille critique a été découverte dans l’implémentation d’OpenSSL de l’extension TLS/DTLS (transport layer security protocols) heartbeat (RFC6520). Cette faille est critique et est référencée par l’identifiant CVE (Common Vulnerabilities and Exposures) CVE-2014-0160.

Lire la suite...

Dates du eurucamp 2014 et appel à propositions

eurucamp 2014 se tiendra à Berlin du 1er août au 3 août. eurucamp est issue de l’EuRuKo 2011.

Lire la suite...

Les places pour la RubyConf Taiwan 2014 sont disponible

La RubyConf Taiwan 2014 se tiendra à Taipei, Taiwan les 25 et 26 avril 2014.

Lire la suite...

Régression de la méthode Hash#reject dans Ruby 2.1.1

Dans les versions de Ruby 2.1.0 et inférieures, la méthode reject des classes héritées de Hash retourne un objet de cette sous-classe. Mais en Ruby 2.1.1, ce comportement a accidentellement changé pour retourner constamment un objet de la classe Hash.

Lire la suite...

Ruby 2.0.0-p451 est disponible

Aujourd’hui 24 février est le 21ème anniversaire de Ruby, nous sommes donc heureux de vous annoncer la sorti d’une version patch : Ruby 2.0.0-p451.

Lire la suite...

Ruby 2.1.1 est disponible

Aujourd’hui, le 24 février 2014 est le 21ème anniversaire de Ruby, par conséquent nous sommes heureux de vous annoncer la sortie d’une nouveau patch de la branche 2.1, Ruby 2.1.1.

Lire la suite...

Ruby 1.9.3-p545 est disponible

Joyeux anniversaire, Ruby ! Aujourd’hui 24 février est le 21ème anniversaire de Ruby. En commémoration de cela, Ruby 1.9.3-p545 est disponible.

Lire la suite...

Nomination des Héros Ruby 2014

Quelqu’un, au sein de la commnunauté, vous a t’il aidé de manière significative cette année ? Peut-être qu’il vous a appris quelque chose, écrit une gem ou vous a apporté une aide technique ? Si quelqu’un vous vient à l’esprit, prenez le temps de le nominer pour une récompense Héros Ruby.

Lire la suite...

Abril Pro Ruby 2014, la conférence tropicale Ruby

Abril Pro Ruby 2014, la troisième édition de la conférence tropicale Ruby, se déroulera le 26 avril 2014 à la plage Porto de Galinhas, un paradis ensoleillé au nord-est du Brésil.

Lire la suite...

Le support de Ruby 1.9.3 s'achèvera le 23 février 2015

Aujourd’hui, nous annonçons le planning de la fin du support de Ruby 1.9.3.

Lire la suite...